Premast Plus
Search…
Supported Versions
Which versions I need to run the add-in
Premast Plus Add-in Now can be run on the following
  • PowerPoint For Mac
  • PowerPoint For Windows
  • PowerPoint On Ipad
  • PowerPoint web
The following table lists the PowerPoint requirement versions for Premast Plus
Minimum
Recommended
Office on Windows
Version 1810
(Build 11001.20074) or later
Version 2011
(Build 13426.20184) or later
Office on iPad
2.17 or later
Office on Mac
16.19 or later
16.43 or later
when you add a template it will be inserted into your current presentation only with recommended version, if your office version is not in the recommended version templates will be opened in a new file
Last modified 8mo ago
Copy link